Jump to content
  • 0

Rockstar Games Launcher won't start



I have a problem with the Rockstar Games Launcher. When I tried to open the launcher, it didn't start up. Instead, I got an error message that said: "The Rockstar Games Launcher failed to initialize! Please visit https://support.rockstargames.com for more information." And so I did. When I issued my ticket, I got a response from the Rockstar Support saying to uninstall Microsoft OneDrive and try to open the launcher again. That didn't work, so I reinstalled the launcher. The installation process went smoothly, no signs of anything wrong happening, but after the reinstallation, the launcher still didn't start up, and I got the same error message as before. So I reinstalled the Launcher again, this time following the reinstallation guide from the support page (deleting the Launcher and Social Club folders). I've also tried updating my drivers, running the launcher with admin's rights, flushing my DNS and so on, but to no effect. Does anybody know the solution to this problem? I'm out of ideas of how to get it to work.

Link to comment

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...